ミギムキ

[WordPress] アップデート時に「The update cannot be installed because WordPress x.x.x requires the JSON PHP extension.」エラーが発生した

WordPressアップデートエラー

WordPressを5.6.1にアップデートしようとした際、以下のようなエラーが発生しました。

The update cannot be installed because WordPress 5.6.1 requires the JSON PHP extension.

JSON用の拡張機能が参照できないからアップデートできない、という内容のエラーです。

対処方法

php.iniに以下の一文を追加した後に再度アップデートを試みたところ、無事成功しました。

extension=json.so
スポンサー広告

蛇足:J-WEBの注意点

今回このエラーが起きたのは、J-WEBというサービスで借りたサーバーに設置したサイトでした。

J-WEBではSSL対応しているサイトとそうでないサイトでphp.iniの参照先が違うようです。

SSL対応しているサイトの場合は「jweb-cgi-bin-ssl」内のphp.iniを、SSL非対応のサイトでは「jweb-cgi-bin」内のphp.iniを編集してください。

ご質問など受け付けています

記事の中でわかりにくかったところ、もっと知りたかったこと、間違っていることなど、何でもお気軽にご連絡ください。

ご連絡は下記フォームを利用いただくか、ツイッターアカウント@flat8migi宛てでもOKです。

スポンサー広告